Issue Identified with multiple third-party integrations
Incident Report for Cuseum
Resolved
We are pleased to report that the issue with third-party integrations using CrowdStrike has been resolved. We have confirmed that all systems are operating as expected. We are still monitoring for any residual impact. If you have any further questions or concerns, please don't hesitate to contact our support team.
Posted Jul 22, 2024 - 18:31 UTC
Monitoring
Blackbaud Altru® and Blackbaud Raiser's Edge NXT® operational again. We are still monitoring Raiser's Edge® and Tessitura outage.
Posted Jul 21, 2024 - 07:34 UTC
Update
We are still monitoring the status of the outage.
Posted Jul 20, 2024 - 05:51 UTC
Identified
We have identified that multiple integrations are impacted by the global IT outage affecting third-party services (CrowdStrike / Windows). We will continue to provide updates on the progress. If you require further information, please do not hesitate to contact our support team.
Posted Jul 19, 2024 - 13:07 UTC
This incident affected: Digital Membership - Integrations ([Third-party] Blackbaud Altru®, [Third-party] Blackbaud Raiser's Edge NXT®, [Third-party] Raiser's Edge®, [Third-party] Tessitura CRM).